Azure Logins fail with Page Not Found

May 20, 2010 at 6:25 PM

Hi ... have followed the installation guide and implemented the Customer Portal Accelerator on Azure. It has been moved to production & renders as expected.

Have used the 'contact us' to create a Lead with known-good WLID in CRMOnline & converted to contact. Have created 'invitation code' & ran 'customer portal sign up invitation' workflow. However, signin to portal with known-good WLID fails with Page Not Found at http://<name>.cloudapp.net/live.axd.

Also, have added another contact with known-good WLID to 'Customer Portal Administrators' at Content Management | Security | Web Roles ... same result when attempting to 'login' to portal.

Have tested from multiple machines ... always same result ... not sure how to troubleshoot.

Would appreciate ideas ... much thanx!

May 20, 2010 at 6:44 PM
Edited May 20, 2010 at 7:00 PM

There is a small bug in the documentation.  The return url should be /LiveID.axd, not /Live.axd.  The Live ID authentication handler is configured as an http handler in your web.config file.  You can use any url you wish, but the web.config and the Live ID portal have to match.  In this case, the documentation said /live.axd and the web.config is set to /LiveID.axd, which do not match.  This will be fixed in the next update of the documentation.

Shan McArthur
www.shanmcarthur.net

May 20, 2010 at 7:36 PM

thanx! what's the eaiest way to get around this? Can you advise?

I'm thinking to edit web.config, rebuild, upload & re-release ... yes?

Again, much thanx!

May 20, 2010 at 9:06 PM

I would go back to the Live ID portal and change the url there.  Future versions of the accelerator will have LiveID.axd as the setting, so unless you want to change it every time you upgrade...  Besides, promoting to Azure is not a very quick operation - it will be faster to change the url in Live ID.

Shan

May 20, 2010 at 9:10 PM

sorry Shan ... I don't understand 'go back to the Live ID portal and change the url there.'

Cheers!

May 20, 2010 at 9:29 PM

Sorry.  When you registered your website with Live ID, you would have used the Live ID portal.  There are many ways to enter that portal, but here is a good link because it explains the process and requirements plus has a managed-link to the current portal:

http://msdn.microsoft.com/en-us/library/bb676626.aspx

- click on the "Live Services Developer Portal" link in the "registering your application" section.  From there, locate your application, click "edit", then change the "Return URL" field to the appropriate link.

Shan

May 20, 2010 at 9:32 PM

'When you registered your website with Live ID' ... doh, must of missed that.

Thanx for the link ... I'll go back & review ... cheers & thanx again!

May 20, 2010 at 9:37 PM

You will want to look at the "Customer Portal Deployment Guid_Azure_V1.0.doc" file.  See steps 16-21.

Shan

May 20, 2010 at 9:53 PM

got it ... thanx!