website

Jun 2, 2010 at 10:19 AM

Hi

I'm trying to deploy the customer portal.

I'm getting error when making changes to the website

The error says

Server Error in '/Website' Application.

The handshake failed due to an unexpected packet format.

 

Please help me with the same.

Thanks

 

Jun 2, 2010 at 2:01 PM

Please follow the instructions in the documentation for how to set up your website.  It looks like you have created a virtual directory and are attempting to host your site out of that.  The portal site is designed to be run as a completely separate website on IIS - and it doesn't even have to be on your CRM server.  If you provide me with more information on how you set up the site, I can probably help you diagnose the error.

Shan McArthur
www.shanmcarthur.net

Jun 3, 2010 at 7:18 AM

Hi

I solved that error and deployed my site properly but now i'm facing another issue.

After deploying the site I'm getting the home page properly but when i check the other links i'm getting the following error.

The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.


Please try the following:

  • Make sure that the Web site address displayed in the address bar of your browser is spelled and formatted correctly.
  • If you reached this page by clicking a link, contact the Web site administrator to alert them that the link is incorrectly formatted.
  • Click the Back button to try another link.

HTTP Error 404 - File or directory not found.
Internet Information Services (IIS)


Technical Information (for support personnel)

  • Go to Microsoft Product Support Services and perform a title search for the words HTTP and 404.
  • Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics titled Web Site Setup, Common Administrative Tasks, and About Custom Error Messages

 

Please help me with the same.

 

Thanks

Mugdha

Jun 3, 2010 at 3:29 PM

If you are getting a 404 error, it is likely you are setting up your site on IIS 6 (Windows 2003).  There is an additional step that was missed in the documentation for setting this up on IIS 6.  Go into your website using IIS Manager, select your website, go to the custom errors tab, select 404 and change the error to redirect to URL /default.aspx.  This is necessary to support the custom urls that the CMS module uses.  IIS 7 takes the settings from the web.config file so it doesn't need this extra step, but IIS 6 requires it.

Shan McArthur
www.shanmcarthur.net

Jun 3, 2010 at 10:31 PM

mugdhamahale -

Could you post the details of how you fixed the 'handshake failed' error?  I'm getting the same one, and I'm not trying to host it out of a virtual directory.

 

Jun 4, 2010 at 12:14 AM

"Server error in /Website" Application indicates that this is running in an application.  Can you send me some screenshots of your IIS configuration for the website and the application pool?  Send it to shan underscore mcarthur at spamcop.net.

Shan

Jun 4, 2010 at 5:32 AM

Hi Shan

My error was solved.i did the IIs configurations as suggested by you and it got solved.

Thanks

Jun 4, 2010 at 5:40 AM

saturdayplace

 

The error was occuring due to the incorrect web service.

the web service link specified was 

https://servername:...

It needs to be http://servername:

Thats how i fixed the error.

 

Thanks

Mugdha