New videos posted

Jun 5, 2010 at 2:48 AM

Hey Everyone,

If you are new to the Customer Portal Accelerator, you might want to slide on over to the updated PRM portal accelerator project and watch the new videos that Reuben has posted.  The current documentation is great, but nothing beats watching a video.  And for those that want a partner version of this portal, you can download the updated PRM portal from that site while you are there.

http://prm.codeplex.com/releases/view/45789

Shan McArthur
www.shanmcarthur.net

Jun 5, 2010 at 10:10 PM
Edited Jun 5, 2010 at 10:28 PM

For CRM Online deployment, I tried to upload the initial website content into CRM following the instruction (video and documentation) but I don't get the similiar response as in the video.  For example, when I run the *.cmd batch file in the same directory as customerportal.xml and websitecopy.exe, the commad prompt appears briefly and then it goes away.  In the video, the command prompt window stays open and shows the execution of the batch file but I do not see that when I run the batch cmd file. 

Thus, I have no way of knowing whether the cmd was executed successffully or not.  Can someone shed some light on this for me?  I believe I created the *.cmd file as instructed with proper data.  Below is the cmd batch file I'm using and I replaced data within <<>> with my own info before I ran the cmd batch file.   Any help would be appreciated.  Thanks,

websitecopy.exe /targetConnectString:"Authentication Type=Passport;
Server=https://<<organization.crm.dyanmics.com/orgID>>; User ID=<<LiveID>>;
Password=<<password>>; Device ID=<<uniqueID>>; Device Password=<<uniquePassword>>; /targetwebsiteName:"Customer Portal"
/sourceFile:customerportal.xml

 

Jun 5, 2010 at 11:15 PM

I would recommend launching cmd.exe to get to the command line, then from there running your .cmd file.  This way you will see any messages and your window won't close.

As far as your command goes, there is no closing quote on the /targetConnectString parameter.  Another issue is that the parameter is /targetConnectionString, not /targetConnectstring  (missing the 'ion')

Good luck!

Shan McArthur
www.shanmcarthur.net

Jun 5, 2010 at 11:38 PM
Edited Jun 6, 2010 at 5:44 AM

Hi Shan,

Thanks for the catching those two typos.  I ran the cmd batch again with "ion" and closing quote but now, I get a command prompt asking for "Target CRM Username:".  When I provide the username, it then asks for password.  When I provide the password, I get usage message followed by:

'Server' is not recognized as an internal or external command,
operable program or batch file.

This message is repeated for 'User" and "Device", etc.

Question is why do I get this error message?  I don't think I have anymore typos.  I guess I must be doing something wrong but I don't know what it is.  Any other ideas?  Here's my batch file with few items xxx'd out.  Thanks in advance.

WebsiteCopy.exe /targetConnectionString:"Authentication Type=Passport;
Server=https://xxxxx.crm.dynamics.com/xxxx;
User ID=xxxx@xxxx.com; Password=xxxxxxx;
Device ID=xxxxxxxx;Device Password=xxxxxxxx;"
/targetWebsiteName:"Customer Portal" /sourceFile:customerportal.xml

Also, if I put the cmd batch file text in single line and run it, I get "WebsiteCopy has stopped working" message.

Jun 6, 2010 at 4:09 PM

The command has to be on a single line - that is how the command shell operates.  The command shell is not a programming language and does not have any multi-line capabilities.

If the program is failing, I would need to see the error message that it is generating.  I would suspect that it would either be that the destination CRM doesn't have the schema imported yet, or because you are using CRM Online, you might not have your Server url set up properly - your unique org name must be included in the path and it might not be what you expect.  In many environments, the unique orgname is a code.  You can go to the download WSDL service descriptions page and find the unique orgname from there.

Shan

Jun 6, 2010 at 4:25 PM
Edited Jun 6, 2010 at 4:44 PM

Hi Shan,

Shall I send you a snap shot of the error messages I got from command prompt?  I have successfully executed previous instructions on importing schema_customizations.zip, exporting & editing  & importing sitemap, and exporting & editing & importing & setting up isvconfig.xml  customizations into CRM Online.  Also, I do have the correct orgname as I have got them from downloaded WSDL.  Device ID and Password I am using are greater than 12 but less than 24 characters - alpha number 18 characters.

Jun 7, 2010 at 9:29 PM

Hi Shan,

Thanks for finding the problem in my command line scripting.  I did not have a space between the end of the quote on the /targetConnectionString argument and the /targetWebsiteName paramter.  Once that was corrected, I was finally able to successfully execute the cmd batch file. 

I have also completed installing Azure piece and now I have the Customer Portal running on Azure with CRM Online.  Thanks,