Content Management Error

Jun 11, 2010 at 2:04 PM
When logged in as a Customer Portal Administrator I get the following error when trying to "edit" website content: "An error has occured while saving your content. Your changes have not been saved." If I client the "New" button and attempt to create a new "Child Page" I get the following error: "An error has occured while loading content required for this feature."
Jun 11, 2010 at 2:59 PM

I just got past that one.   The issue for us, was that I didn't have the .net 3.5 sp1 components "turned on".     Go to "Add windows components" in the control panel (Add/remove programs or Programs and features area) you will need to check the two boxes for http and https.   (Added on the webserver and on the PC trying to do the editing - worked for me)

Jun 11, 2010 at 6:13 PM
Which area in "Windows Components" are you referring to? I cannot find the http / https options that you have detailed Do I need to click the "Detail" button on one of the components?
Jun 11, 2010 at 7:22 PM

First, make sure that you have .NET 3.5 SP1 installed on your webserver.  On your webserver go into Control panel > Programs and Features (or Add Remove Programs - depending which version of Server you are running).    In the left nav panel you will see "Turn Windows Features on or off" (something like that).   The Server Manager will open, Click "Features", on the right click "Add Features" Under the .NET 3.0 section, expand it until you see the WCF section, expanding that will show you the HTTP and HTTPS Activation.   Install both, IISRESET and you should be good to go.

I also did this on my local machine (slightly different on a non server OS, but the basic instructions above will get you there).   Not sure if it was needed on the local PC or not, but figured it couldn't hurt.

Jun 13, 2010 at 12:53 PM
Anybody know how to do this on Windows Server 2003? Unfortunately, the instructions for Windows Server 2008 above don't help
Jun 13, 2010 at 1:30 PM
I found the answer in another discussion: Add the following to the web.config file: <serviceHostingEnvironment aspNetCompatibilityEnabled="true"> <baseAddressPrefixFilters> <add prefix=""></add> </baseAddressPrefixFilters> </serviceHostingEnvironment>