LiveID return URL

Jun 23, 2010 at 8:02 AM

I have the portal up and running in a dev environment using an HTTP url. However my production site which uses https is having a problem returning from the LiveID login page. The return URL is comming pack with a ":80"

https://domain.com:80/confirm-invite?LoginURL=%2fDefault.aspx

The LiveID is configured properly with https and I even tried adding :443 to the return URL.

Any idea where the :80 is comming from? Anyone else using https?

Webserver is IIS6

Jun 23, 2010 at 2:48 PM
This is a known issue that has been fixed and will be included in the next dop of the CRM SDK and portal accelerator update. There are some workarounds, but they require some complex coding, so I would recommend waiting a few weeks for the update. Shan McArthur www.shanmcarthur.net
Jun 24, 2010 at 2:00 AM

Thanks Shane,

Is there a place I can find info on the work arounds?

Also, Thanks for all the hard work on the portal!

Jul 2, 2010 at 8:26 AM

Hi Shan, thank you for confirming this is a known issue, it was driving me mad! 

Do you have any idea when the udpated code base will be release with this item resolved?

If its not due soon are you able to provide some pointers for us to try and resolve ourselves as we have an urgent HTTPS requirement?

Thanks,

Michael Jarvis
Director of Consulting Service
Gap Consulting Ltd.

Jul 5, 2010 at 2:09 PM

The update should ship in July.  The bug is in the handler, where it adds :80 on to the request, and https://domain:80/ is not a valid url.  The workaround is to also allow port 80, and allow the authentication handler to function on port 80, then redirect to SSL for rendering pages.  This will involve an extra redirect, but will work in a pinch.  No credentials are being passed over the wire, and everything from Live ID is encrypted, so your security is still reasonably high with this configuration.

Shan

Jul 27, 2010 at 3:52 PM

Hi Shan,

We're approaching the end of July, but I didn't see an update to this post yet.  Has the update shipped?

Jul 27, 2010 at 4:43 PM

No it has not been shipped yet.

Jul 27, 2010 at 5:30 PM
Edited Jul 27, 2010 at 5:31 PM

Hi Shan,

Do you have an idea of when the new handler will be available, or is it maybe a dll (or similar) which can be issued as a point release rather than waiting for the full release?

Many thanks,

Michael Jarvis
Director of Consulting Service
Gap Consulting Ltd.

Dec 1, 2010 at 2:16 PM

Hi,

is there anything new about this topic? I only can find a download from may. Hasn't there been any update yet?

Jürgen

Dec 2, 2010 at 3:23 PM

The bug in the framework has been fixed.  You can download the latest SDK (4.0.13) and update your portals with the latest DLLs to resolve the issue.

Shan

Dec 7, 2010 at 8:00 AM

Oh, thanks I didn't realize that I have to change the dll from the CRM SDK. But nevertheless it did not help. I copied the files microsoft.crm.sdk.dll, microsoft.crm.sdktypeproxy.dll and microsoft.crm.sdktypeproxy.xmlserializers.dll from the CRM SDK 4.0.13 into the bin folder of the website. After that I did a IIS Reset on the Portal Server and the CRM Server, but nevertheless I still have got Port 80 in the return URL. Is there anything I am missing?

Dec 7, 2010 at 5:28 PM

You also need the portal dlls.  Replace the client, portal, and files DLLs as well.

Dec 8, 2010 at 8:07 AM

Hi, I replaced the client, portal und files dlls, as that wasn't working I also replaced the client and portal xml and the AntiXSSLibrary dll. Now I get this error:

Configuration Error

Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: Unable to create instance of ICrmDataContext type "Xrm.XrmDataContext". Please review your configuration.

Source Error:

Line 53: 		<roleManager enabled="true" defaultProvider="CrmRoleProvider">
Line 54: 			<providers>
Line 55: 				<add name="CrmRoleProvider" type="Microsoft.Xrm.Portal.Web.Security.CrmContactRoleProvider"/>
Line 56: 			</providers>
Line 57: 		</roleManager>
Dec 8, 2010 at 2:59 PM

I solved this by creating a new Xrm.cs File with the CrmSvcUtil Tool and then recompiling the Project.

Apr 25, 2011 at 7:56 AM

Hi,

I have faced same problem that has been mentioned in this post and applied the fix.

I have generated XRM.cs and rebuilt and overcome the error. But now the portal works with http version correctly but not with https one.

Could you please update me if there are any solution to make portal work for https? or I need to use some other accelerator like  AdxSutdio?

Right now I am using all CRM  dll's of version 4.4.

 

Thanks

Vijay Annem

 

Apr 25, 2011 at 1:29 PM

What do you mean by "right now I am using all CRM dll's of version 4.4"?

You should not have any problems using https with the latest dlls from the latest CRM SDK, which I think is 4.0.14.  You will have to ensure that your Live ID application is set to use https.

May 4, 2011 at 8:01 AM

The problem got resolved whe xrm related dlls are replaced from MSCRM SDK.

Thanks for comments