*WEB* filters not working?

Jul 16, 2010 at 5:37 AM

I got everything up and running after running into a few headaches here and there.

The only thing I can't seem to get going is showing the service activities and case updates.  I am putting in the *WEB* keyword from the CRM side but that doesn't seem to resolve it.  Any notes in a case entered by a user works...?

Any ideas?

Cheers

Nick

Jul 20, 2010 at 2:40 PM

Hi Nick,

I'm not sure I fully understand your problem.  Are you having an issue viewing the case notes from the web portal or are you not seeing any services in the drop down menu?  If you could provide me with a little more detail I'd love to help you troubleshoot this.

Christine Fischer – Developer
Adxstudio Inc. 

Jul 20, 2010 at 3:30 PM
Hi, I am also having the same issue. If I am in CRM and add a note, my understanding is that if I put *WEB* in the note then when users login to the portal they should be able to see the note. However, this does not work. However, if I create a note in the portal it does go into CRM with the *WEB* in the note description, and does show in both CRM and the portal. How do you get notes added by the support person in CRM to show in the portal? Thanks Judy
Jul 20, 2010 at 3:55 PM
Hi Christine My problem is exactly what Judy said. Does that make sense? Cheers Nick
Sep 15, 2010 at 8:15 PM

Does anyone have an update on this issue. This is causing us alot of pain.

Sep 15, 2010 at 9:31 PM

I believe that the issue is that there is an issue with the caching mechanism of the LINQ data sources Xrm.XrmDataContext used by the Customer Portal Accelerator. You can find more information here:

http://www.xrmlinq.com/crm-sdk-4-0-12-bugs-limitations/

There are a few ways around this that you can read about at the link below, but I haven't looked into modifying the Customer Portal as of yet:

http://social.microsoft.com/Forums/en-US/crmdevelopment/thread/3d4a2501-3d02-4f39-bae7-790db0c0e633

 

 

 

 

 

Sep 20, 2010 at 6:06 PM

Hi All,

Here's a solution to your caching problem that you've discribed. 

  1. Open the "Case" entity from the Customizations menu.  (Settings -> Customization ->Customize Entities -> Case)
  2. From the Details pane select "Forms and Views"
  3. Open the Form and select "Form Properties" from the Common Tasks pane
  4. On the Events tab, select the OnSave event and click Edit
  5. Make sure the "Event is enabled" checkbox is selected and paste the following javascript into the textarea (be sure to add your URL to the src attribute):
var doc = window.top.document;
var iframe = doc.createElement('iframe');
iframe.setAttribute('src', 'http://PASTE_YOUR_URL_HERE/Cache.axd?Message=Create&EntityName=case');
iframe.setAttribute('style', 'display:none;visibility:hidden;height:0;width:0;');
iframe.setAttribute('height', '0');
iframe.setAttribute('width', '0');
doc.body.appendChild(iframe);

6.  Select Ok to close the event details window
7.  Ok to close the form properties window
8.  Save and Close the form
9.  On the Case entity select Actions -> Publish
10. Save and Close

Hope this helps
Christine