1
Vote

using WebsiteCopy with IIS7

description

Has anyone installed this using IIS7? Websitecopy keeps falling over. The console window display 401 unauthorisation error. I have supplied valid admin username and password. The user exists on the new organisation I have created. The new organisation is a default organisation, and I have applied all CRM customisations to this organistaion. Can anyone provide any directions?

comments

techno_guy wrote Jun 18, 2010 at 3:09 PM

I have installed it successfully on IIS 7.0, infact I was getting that same error message of 401. What you need to do is to check your websitecopy.exe command. Make sure that the syntax is right.

Regards
Zack

abhisekh wrote Dec 27, 2012 at 9:35 AM

hi,

even me getting the same thing with this error......

Unhandled Exception: System.Configuration.ConfigurationErrorsException: The spec
ified device credentials are invalid.
at Microsoft.Xrm.Client.CrmConnection..ctor(String serviceUri, String homeRea
lmUri, String domain, String userName, String password, String deviceId, String
devicePassword, String timeout, String proxyTypesEnabled, String proxyTypesAssem
bly, String callerId, String serviceConfigurationInstanceMode, String userTokenE
xpiryWindow)
at Microsoft.Xrm.Client.CrmConnection..ctor(IDictionary`2 connection)
at Microsoft.Xrm.Client.CrmConnection.Parse(String connectionString)
at WebsiteCopy.WebsiteImporter.Import(XElement element, String websiteName)
at WebsiteCopy.WebsiteImporter.Import(XmlReader reader, String websiteName)
at WebsiteCopy.WebsiteImporter.Import(Stream input, String websiteName)
at WebsiteCopy.WebsiteImporter.Import(String inputXml, String websiteName)
at WebsiteCopy.Copier.Copy(String[] args)
at WebsiteCopy.Program.Main(String[] args)

wrote Feb 14, 2013 at 9:21 PM